Questions about NCAP_CEH and FLO_SHAR in VEDA-FE
#1
Hi, 
        I am trying to build a energy system model in VEDA-FE based on a model in ANSWER. When I want to transfer the "NCAP_CEH" data to a FE form, I can not find a corresponding attribute in VEDA-FE after searching the parameter in attribute master. Where can I find the corresponding parameter?
       Second question is about FLO_SHAR, can I define a UP or LO bound about FLO_SHAR in FE? If I can't, what shall I do the set a flexible share in FE? I can do that in ANSWER, maybe there is a way in FE to do so.
Reply
#2
I think you can do in VEDA-FE mostly all what you can in ANSWER, but in some cases attribute names may be different.
Concerning NCAP_CEH, please search for CEH in the Parameter box at the top of Attributes master, and you should find VDA_CEH (=alias for NCAP_CEH).

Of course, you must define a bound type with FLO_SHAR. The parameter will not work without a bound. In VEDA-FE, you can put it in the LimType column, or you can use the ~ syntax in the columns of FI_T tables.

Please consider posting VEDA-related questions on the VEDA Forum, as the VEDA experts are mostly lurking there and not here (I am not one).
Reply
#3
(04-05-2020, 07:10 PM)Antti-L Wrote: I think you can do in VEDA-FE mostly all what you can in ANSWER, but in some cases attribute names may be different.
Concerning NCAP_CEH, please search for CEH in the Parameter box at the top of Attributes master, and you should find VDA_CEH (=alias for NCAP_CEH).

Of course, you must define a bound type with FLO_SHAR. The parameter will not work without a bound. In VEDA-FE, you can put it in the LimType column, or you can use the ~ syntax in the columns of FI_T tables.

Please consider posting VEDA-related questions on the VEDA Forum, as the VEDA experts are mostly lurking there and not here (I am not one).


Thank you very much Antti! 
      I know how to deal with CEH parameters now. But in Attribute Master , as you can see
[Image: UAGD1Cb9LYzj5lV.png]

the Limtype is only FX. I have tried to set "UP""LO" in the LimType column in FI~T table , but in FE it changed to "FX". Do you know why? I can write a new thread in VEDA Forum if necessary.
Reply
#4
can you attach a screen shot of exactly how to tried to specify the limtype?
Reply
#5
(04-05-2020, 10:53 PM)AKanudia Wrote: can you attach a screen shot of exactly how to tried to specify the limtype?


[Image: PeQIonBt1mZUMGL.png]
Reply
#6
this looks OK. Can you also post a screen shot of this process in Browse?
Reply
#7
(05-05-2020, 11:41 AM)AKanudia Wrote: this looks OK. Can you also post a screen shot of this process in Browse?


[Image: y56OoxRj7nBTCSf.png]
Reply
#8
Assuming that you have synchronized the model after introducing LimType, this col seems to be ignored, and visually I can't see any reason why it should be. Another possibility is that this declaration is coming from some other table in the same file, or the trans file. but the "LO" share records should have survived in that case.

try changing the table tag to "~FI_T: LO". This will make limtype default to LO for the entire table.
Reply
#9
(05-05-2020, 03:14 PM)AKanudia Wrote: Assuming that you have synchronized the model after introducing LimType, this col seems to be ignored, and visually I can't see any reason why it should be. Another possibility is that this declaration is coming from some other table in the same file, or the trans file. but the "LO" share records should have survived in that case.

try changing the table tag to "~FI_T: LO". This will make limtype default to LO for the entire table.


Thank you very much! It works well!
Reply
#10
(05-05-2020, 03:14 PM)AKanudia Wrote: Assuming that you have synchronized the model after introducing LimType, this col seems to be ignored, and visually I can't see any reason why it should be. Another possibility is that this declaration is coming from some other table in the same file, or the trans file. but the "LO" share records should have survived in that case.

try changing the table tag to "~FI_T: LO". This will make limtype default to LO for the entire table.



I found my settings on LimType in other attribute like NCAP_CHPR existing the same problem. Using the "~FI_T:LO" way makes me to separate one table to three tables(UP,LO,FX). Can I find another way to solve the problem? Should I check my syssetting file? Like TFM_UPD table?
[Image: yGjTJ8gVeasfBZP.png]
Reply
#11
There are no values declared for NCAP_CHPR... not sure I understand your question.

Are you working in a group?
Reply
#12
(09-05-2020, 07:20 PM)AKanudia Wrote: There are no values declared for NCAP_CHPR... not sure I understand your question.

Are you working in a group?

I want to find a way to improt LimType to FE. As you advice, I can use "FI_T:LO" to import LO bound and it works well. If the LimType column works well, I can define all NCAP_CHPR data in one table. But if I use "FI_T:LO" and "FI_T:UP", I need to define two table. There are many other data in different regions and sectors which I need to deal with, I want to know why the LimType column didn't work to mininize the number of tables and simplify my work.
Does the LimType column of TFM_UPD table defines the available bound type of specific attribute in the whole model? 
I am a beginner of FE, and working in a group. But I work alone in the model building work on FE.
Reply
#13
LimType column works in FI_T as well as all TFM tables. My suggestion to use FI_T: LO was only to diagnose the problem. There must be some special characters or something else in the col header "LimType" in that table where it did not work. I can take a look if you send me that file.

Is anyone else in your group more familiar with Veda? There is a fairly steep learning curve, and I am not aware of any user who has managed without a training course.
Reply
#14
(10-05-2020, 04:43 PM)AKanudia Wrote: LimType column works in FI_T as well as all TFM tables. My suggestion to use FI_T: LO was only to diagnose the problem. There must be some special characters or something else in the col header "LimType" in that table where it did not work. I can take a look if you send me that file.

Is anyone else in your group more familiar with Veda? There is a fairly steep learning curve, and I am not aware of any user who has managed without a training course.


I can show you the file in attachment


Attached Files
.xlsx   FLO_SHAR.xlsx (Size: 12.23 KB / Downloads: 2)
Reply
#15
I think Amit asked for the file where defining the bound type as "LO" under the LimType column does not seem to work, but you see FX instead in the Browser. Are you sure that LO in the example you provided does not work?

I tried the example you provided (with the DEMO model), and obtained LimType=LO both with just using ~FI_T (and so when not adding it to the tag ~FI_T: LO):

[Image: attachment.php?aid=114]


Attached Files Thumbnail(s)
   
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)