Non solvable model with new Answer TIMES version
#1
We have a model that is solvable in an older Answer TIMES version (6.9.7) but not in the latest version (6.9.24). Does anyone have any tips on what is causing this? In previous model updates we have a few times needed to change the type of parameters that is used to make the model solvable. I assume this can solve the problem this time as well, but I do not quite understand what is causing the problem.
 
All help is highly appreciated!


 
 
Reply
#2
I am not fully sure what you mean by "not solvable in the latest version". Do you mean that you have upgraded only AnswerTIMES, or the TIMES code as well?  Could you also elaborate what you mean by saying that you have "a few times needed to change the type of parameters that is used to make the model solvable"?

If the model should be the same (i.e. you have not made any changes in the model while switching to the new version), I think it would be relatively easy to compare the *.DD* files (and the GEN file), and see if they are different. If they are indeed different, then the problem is probably caused by that, and you can check why they are different under the new version.

If your TIMES version has changed as well, it would also be easy to test with the earlier TIMES version and see if the problem is somehow related to TIMES versions.  If you find out that the model still solves with the earlier TIMES version but not with the new, could you then please send me the model input files (*.DD*, *.GEN) for my further investigation, and provide the TIMES version information.
Reply
#3
It is unfortunate that the issue you reported still appears to remain unresolved, after so many weeks passed.

I have basically no idea what might be causing the model becoming "not solvable in the latest version", but the problem sounds quite serious to me. In my view nothing of that kind should of course happen when you upgrade the modeling software.

Thus, it would be very nice if you could give any more information about the problem. As you posted the question in the TIMES sub-forum, I would be specifically interested to know whether the problem is actually related to TIMES, or just to the ANSWER software.
Reply
#4
Dear Anttil,

First, I apologise very much for my late reply the forum. I must have overlooked the reply among my e-mails. I will check the DD-files and the TIMES version. I will also send you the DD-files if the TIMES-versions is the same.

I am also currently in dialogue with Ken that is helping me to look at the problem. I do not know if it is related to Answer or TIMES, but I will inform the forum when we know.

Pernille
Reply
#5
Update: Thanks to Pernille having provided the input files, the issue was resolved.

The difference in the model solvability was not caused by ANSWER versions, but by different TIMES versions, such that when running with v4.1.3 the model was feasible, due to a bug in that version of TIMES, while when running with v4.1.6−4.2.7 the model was correctly reported infeasible, due to the earlier bug having been fixed since TIMES v4.1.6.

The infeasibility was caused by FLO_FUNC being (apparently mistakenly) used for defining the fuel efficiency of each fuel within a group of input fuels, which were presumably meant to be substitutable input fuels.
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)