CHP modelling
#1
Hello all,

Is it possible that only electricity will be produced by the CHP if the CHPR value inputted is a fixed value? In my case I have inputted CHPR~FX as 1.47 and CEH as 1. But the entire capacity of the CHP is being used to produce electricity.
Reply
#2
No, it should not be possible (if the process is defined to be of type CHP).  Note that if you define CEH=1, the activity and capacity represent the total energy output (power+heat) in full CHP mode, as described in the documentation.

Can you maybe provide the model input files (*.DD and *.RUN) for investigating why you have the issue, or is there anything else I could do to help with the issue?

[EDIT:] I just tested it for a test process "MYCHP" of type CHP, using the parameters you have given:
NCAP_CHPR(REG,2010,MYCHP,FX)= 1.47;
NCAP_CEH(REG,2010,MYCHP) = 1;

In the results, the outputs were electricity and heat exactly in the fixed proportions defined, as expected. So, I cannot confirm your findings.
Reply
#3
(19-04-2019, 10:50 PM)Antti-L Wrote: No, it should not be possible (if the process is defined to be of type CHP).  Note that if you define CEH=1, the activity and capacity represent the total energy output (power+heat) in full CHP mode, as described in the documentation.

Can you maybe provide the model input files (*.DD and *.RUN) for investigating why you have the issue, or is there anything else I could do to help with the issue?

[EDIT:] I just tested it for a test process "MYCHP" of type CHP, using the parameters you have given:
NCAP_CHPR(REG,2010,MYCHP,FX)= 1.47;
NCAP_CEH(REG,2010,MYCHP) = 1;

In the results, the outputs were electricity and heat exactly in the fixed proportions defined, as expected. So, I cannot confirm your findings.


Thanks for your quick reply. I have attached a screenshot of the processes I have defined in my input sheet (just for reference). These processes could be seen in detail in the sub_RES file I am attaching. I am very new to TIMES. I don't know where to find .DD and .RUN file. I can give all the required excel sheets if you want (base year template, SysSettings file etc.)


Attached Files Thumbnail(s)
   

.xls   SubRES_BackupBoilers.xls (Size: 112 KB / Downloads: 1)
Reply
#4
In the VEDA-FE Case Manager there is a box called "GAMS Work folder", and the *.DD and the *.RUN files are written there, for each model run.  There is also a file called QA_Check.log, which includes error and warning messages. Please have a look at that file, and see if there are some errors.

I suspect that maybe you have not defined the processes to be of type CHP. See the documentation, Part II, Section 2.2.1.1.1  Standard processes, and  Section 4.1.2  Defining CHP attributes in TIMES, which describe how CHP processes should be defined CHP processes.  It seems that in your Subres file you have defined all processes as 'PRC' in the ~FI_Process table, so it looks like none of them is CHP.
Reply
#5
(21-04-2019, 12:15 AM)Antti-L Wrote: In the VEDA-FE Case Manager there is a box called "GAMS Work folder", and the *.DD and the *.RUN files are written there, for each model run.  There is also a file called QA_Check.log, which includes error and warning messages. Please have a look at that file, and see if there are some errors.

I suspect that maybe you have not defined the processes to be of type CHP. See the documentation, Part II, Section 2.2.1.1.1  Standard processes, and  Section 4.1.2  Defining CHP attributes in TIMES, which describe how CHP processes should be defined CHP processes.  It seems that in your Subres file you have defined all processes as 'PRC' in the ~FI_Process table, so it looks like none of them is CHP.


@Antii-L. Yes, you were right, it was not defined as CHP. However, still only electricity is being produced. I tried many options and could not solve the problem. Could you have a look at it? I am attaching the .DD and .RUN files for your use.

Thanks in advance.


Attached Files
.zip   DD n Run files.zip (Size: 338.74 KB / Downloads: 1)
Reply
#6
You have left one important DD file missing in the ZIP file: base.dd

I cannot reproduce the run without it, so maybe you can upload that as well?
Reply
#7
(22-04-2019, 01:06 AM)Antti-L Wrote: You have left one important DD file missing in the ZIP file:  base.dd

I cannot reproduce the run without it, so maybe you can upload that as well?


Sorry. Again I am uploading all files together. Please ignore previous files and take these latest ones.


Attached Files
.zip   DD n Run files.zip (Size: 6.48 MB / Downloads: 2)
Reply
#8
Ok, thanks.  
It was easy to see what the problem was: Your CHP processes do not have any electricity output. You would have seen it easily from the QA_Check.log, where these warnings were given:

*** Found CHP processes without electricity in the PG
*01 WARNING       -     R=BE           P=EPLT_CHPBIOnew
*01 WARNING       -     R=BE           P=EPLT_CHPENnew
*01 WARNING       -     R=BE           P=EPLT_CHPGTnew

As you have no outputs defined to be electricity, it should be obvious that the CHP parameters cannot work: How do you suppose the NCAP_CHPR could work without any output being defined to be electricity?

Sure, these processes have a commodity named ELC as an output, but you have to define that commodity as an electricity commodity if you want to use the CHP parameters. You can do that in the ~FI_Comm table, by putting ELC in the Ctype column.

I tested your model with that correction, and the CHPR ratios then worked as expected.

But you have other problems with your CHP parameters. I can see that you have changed the efficiencies from your earlier version, and that your new CHP parameters no longer make sense.

1) You are now apparently defining electrical efficiencies (28%−60%), while in your earlier Subres file you apparently defined total efficiencies (they were 96%−110%). But you are still defining NCAP_CEH=1, which should only be used if you define the efficiencies in terms of total power+heat output!  Did you read the documentation (Table 18)?
2) Even if you remove the NCAP_CEH=1 specifications, your new efficiencies still don't look sensible. Example: You define an efficiency of 60% for EPLT_CHPGTnew in 2050, and CHPR=1.47. So, your total efficiency would be 0.6*(1+1.47)=1.482.  I think such a high efficiency is not possible for a CCGT CHP plant.

Because your costs seem to be per electrical capacity, I would recommend to remove the NCAP_CEH=1 parameters, but you should also correct your electrical efficiencies (and/or your CHPR). Dividing your original efficiencies (which were between 96% and 110%) by (1+CHPR) would be seem to be a good starting point.
Reply
#9
(22-04-2019, 06:09 AM)Antti-L Wrote: Ok, thanks.  
It was easy to see what the problem was: Your CHP processes do not have any electricity output. You would have seen it easily from the QA_Check.log, where these warnings were given:

*** Found CHP processes without electricity in the PG
*01 WARNING       -     R=BE           P=EPLT_CHPBIOnew
*01 WARNING       -     R=BE           P=EPLT_CHPENnew
*01 WARNING       -     R=BE           P=EPLT_CHPGTnew

As you have no outputs defined to be electricity, it should be obvious that the CHP parameters cannot work: How do you suppose the NCAP_CHPR could work without any output being defined to be electricity?

Sure, these processes have a commodity named ELC as an output, but you have to define that commodity as an electricity commodity if you want to use the CHP parameters. You can do that in the ~FI_Comm table, by putting ELC in the Ctype column.

I tested your model with that correction, and the CHPR ratios then worked as expected.

But you have other problems with your CHP parameters. I can see that you have changed the efficiencies from your earlier version, and that your new CHP parameters no longer make sense.

1) You are now apparently defining electrical efficiencies (28%−60%), while in your earlier Subres file you apparently defined total efficiencies (they were 96%−110%). But you are still defining NCAP_CEH=1, which should only be used if you define the efficiencies in terms of total power+heat output!  Did you read the documentation (Table 18)?
2) Even if you remove the NCAP_CEH=1 specifications, your new efficiencies still don't look sensible. Example: You define an efficiency of 60% for EPLT_CHPGTnew in 2050, and CHPR=1.47. So, your total efficiency would be 0.6*(1+1.47)=1.482.  I think such a high efficiency is not possible for a CCGT CHP plant.

Because your costs seem to be per electrical capacity, I would recommend to remove the NCAP_CEH=1 parameters, but you should also correct your electrical efficiencies (and/or your CHPR). Dividing your original efficiencies (which were between 96% and 110%) by (1+CHPR) would be seem to be a good starting point.



Now it's working alright. Thanks for your patience and your suggestions on inputting the efficiency.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)